import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "I like (?!foo(?!d|tball))[^ ]+";
final String string = "I like foo << - not allowed\n"
+ "I like fooSomeRandomString << - not allowed\n"
+ "I like food << - allowed\n"
+ "I like football << - allowed\n"
+ "I like drawing << - allowed\n"
+ "I dislike drawing << - not allowed";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}