$re = '/I like (?!foo(?!d|tball))[^ ]+/m';
$str = 'I like foo << - not allowed
I like fooSomeRandomString << - not allowed
I like food << - allowed
I like football << - allowed
I like drawing << - allowed
I dislike drawing << - not allowed';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);