import re
regex = re.compile(r"I like (?!foo(?!d|tball))[^ ]+", flags=re.MULTILINE)
test_str = ("I like foo << - not allowed\n"
"I like fooSomeRandomString << - not allowed\n"
"I like food << - allowed\n"
"I like football << - allowed\n"
"I like drawing << - allowed\n"
"I dislike drawing << - not allowed")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")