# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<ID>.+?)=(?<Translation>(?:(?!\S+\s*=)[\s\S])+)//gm;t' <<< "xxx_error_tx1 = This is xxxx. Johe say:
xxx_error_MapCode = xxx_error_tx1, test this function,Failed,\
Default, Current,\
App_Error_tx1"