use strict;
my $str = 'xxx_error_tx1 = This is xxxx. Johe say:
xxx_error_MapCode = xxx_error_tx1, test this function,Failed,\\
Default, Current,\\
App_Error_tx1';
my $regex = qr/(?<ID>.+?)=(?<Translation>(?:(?!\S+\s*=)[\s\S])+)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";