import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<ID>.+?)=(?<Translation>(?:(?!\\S+\\s*=)[\\s\\S])+)";
final String string = "xxx_error_tx1 = This is xxxx. Johe say:\n"
+ "xxx_error_MapCode = xxx_error_tx1, test this function,Failed,\\\n"
+ " Default, Current,\\\n"
+ " App_Error_tx1";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}