re = /(?<ID>.+?)=(?<Translation>(?:(?!\S+\s*=)[\s\S])+)/m
str = 'xxx_error_tx1 = This is xxxx. Johe say:
xxx_error_MapCode = xxx_error_tx1, test this function,Failed,\\
Default, Current,\\
App_Error_tx1'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result