#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:[01]\d|2[0123]):(?:[012345]\d):(?:[012345]\d)$"
Local $sString = "00:12:45" & @CRLF & _
"23:65:67" & @CRLF & _
"23:56:00" & @CRLF & _
"01:60:89" & @CRLF & _
"12:59:59" & @CRLF & _
"20:30:30" & @CRLF & _
"2020-05-29 20:30:30 -0600"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)