using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[01]\d|2[0123]):(?:[012345]\d):(?:[012345]\d)$";
string substitution = @"";
string input = @"00:12:45
23:65:67
23:56:00
01:60:89
12:59:59
20:30:30
2020-05-29 20:30:30 -0600";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}