const regex = /^(?:[01]\d|2[0123]):(?:[012345]\d):(?:[012345]\d)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[01]\\d|2[0123]):(?:[012345]\\d):(?:[012345]\\d)$', 'gm')
const str = `00:12:45
23:65:67
23:56:00
01:60:89
12:59:59
20:30:30
2020-05-29 20:30:30 -0600`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);