import re
regex = re.compile(r"^(?:[01]\d|2[0123]):(?:[012345]\d):(?:[012345]\d)$", flags=re.MULTILINE)
test_str = ("00:12:45\n"
"23:65:67\n"
"23:56:00\n"
"01:60:89\n"
"12:59:59\n"
"20:30:30\n"
"2020-05-29 20:30:30 -0600")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)