use strict;
my $str = '00:12:45
23:65:67
23:56:00
01:60:89
12:59:59
20:30:30
2020-05-29 20:30:30 -0600';
my $regex = qr/^(?:[01]\d|2[0123]):(?:[012345]\d):(?:[012345]\d)$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";