const regex = /(cph)[0-9]+\.(?:jpeg|jpg|png|JPG)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(cph)[0-9]+\\.(?:jpeg|jpg|png|JPG)', 'g')
const str = `Hello de lu!
Ce we c'était petite balade à Chamrousse, ça décrasse ça 4 photos de la sortie :
[img]https://monforum/upload/cph20210412114443.png[/img]
[img]https://monforum/upload/cph20210412114458.JPG[/img]
[img]https://monforum/upload/cph20210412114511.jpeg[/img]
[img]https://monforum/upload/cph20210412114525.jpg[/img]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}