// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(cph)[0-9]+\.(?:jpeg|jpg|png|JPG)").unwrap();
let string = "Hello de lu!
Ce we c'était petite balade à Chamrousse, ça décrasse ça 4 photos de la sortie :
[img]https://monforum/upload/cph20210412114443.png[/img]
[img]https://monforum/upload/cph20210412114458.JPG[/img]
[img]https://monforum/upload/cph20210412114511.jpeg[/img]
[img]https://monforum/upload/cph20210412114525.jpg[/img]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}