use strict;
my $str = 'Hello de lu!
Ce we c\'était petite balade à Chamrousse, ça décrasse ça 4 photos de la sortie :
[img]https://monforum/upload/cph20210412114443.png[/img]
[img]https://monforum/upload/cph20210412114458.JPG[/img]
[img]https://monforum/upload/cph20210412114511.jpeg[/img]
[img]https://monforum/upload/cph20210412114525.jpg[/img]';
my $regex = qr/(cph)[0-9]+\.(?:jpeg|jpg|png|JPG)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}