$re = '/(cph)[0-9]+\.(?:jpeg|jpg|png|JPG)/';
$str = 'Hello de lu!
Ce we c\'était petite balade à Chamrousse, ça décrasse ça 4 photos de la sortie :
[img]https://monforum/upload/cph20210412114443.png[/img]
[img]https://monforum/upload/cph20210412114458.JPG[/img]
[img]https://monforum/upload/cph20210412114511.jpeg[/img]
[img]https://monforum/upload/cph20210412114525.jpg[/img]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);