# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(cph)[0-9]+\.(?:jpeg|jpg|png|JPG)"
test_str = ("Hello de lu!\n"
"Ce we c'était petite balade à Chamrousse, ça décrasse ça 4 photos de la sortie : \n\n"
"[img]https://monforum/upload/cph20210412114443.png[/img]\n\n"
"[img]https://monforum/upload/cph20210412114458.JPG[/img]\n\n"
"[img]https://monforum/upload/cph20210412114511.jpeg[/img]\n\n"
"[img]https://monforum/upload/cph20210412114525.jpg[/img]")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.