#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[^\w-:])[+-]?\d+(?=\s|$)"
Local $sString = "" & @CRLF & _
"id = 1" & @CRLF & _
"id = 1 and lpo=2" & @CRLF & _
"id = -1" & @CRLF & _
"id=-1" & @CRLF & _
"id=1" & @CRLF & _
"id >-1" & @CRLF & _
"id >1" & @CRLF & _
"id > -1" & @CRLF & _
"id > 1" & @CRLF & _
"id<-1" & @CRLF & _
"id<1" & @CRLF & _
"id > -1" & @CRLF & _
"id > 1" & @CRLF & _
"date=22-11-2014" & @CRLF & _
"date = 22-11-2014" & @CRLF & _
"date = 22-11-2014 00:00:00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")