re = /(?<=[^\w-:])[+-]?\d+(?=\s|$)/m
str = '
id = 1
id = 1 and lpo=2
id = -1
id=-1
id=1
id >-1
id >1
id > -1
id > 1
id<-1
id<1
id > -1
id > 1
date=22-11-2014
date = 22-11-2014
date = 22-11-2014 00:00:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end