using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[^\w-:])[+-]?\d+(?=\s|$)";
string input = @"
id = 1
id = 1 and lpo=2
id = -1
id=-1
id=1
id >-1
id >1
id > -1
id > 1
id<-1
id<1
id > -1
id > 1
date=22-11-2014
date = 22-11-2014
date = 22-11-2014 00:00:00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}