import re
regex = re.compile(r"(?<=[^\w-:])[+-]?\d+(?=\s|$)", flags=re.MULTILINE)
test_str = ("\n"
"id = 1\n"
"id = 1 and lpo=2\n"
"id = -1\n"
"id=-1\n"
"id=1\n"
"id >-1\n"
"id >1\n"
"id > -1\n"
"id > 1\n"
"id<-1\n"
"id<1\n"
"id > -1\n"
"id > 1\n"
"date=22-11-2014\n"
"date = 22-11-2014\n"
"date = 22-11-2014 00:00:00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")