const regex = /(?<=[^\w-:])[+-]?\d+(?=\s|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[^\\w-:])[+-]?\\d+(?=\\s|$)', 'gm')
const str = `
id = 1
id = 1 and lpo=2
id = -1
id=-1
id=1
id >-1
id >1
id > -1
id > 1
id<-1
id<1
id > -1
id > 1
date=22-11-2014
date = 22-11-2014
date = 22-11-2014 00:00:00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}