const regex = /(?:(?:^|(?<=@))([^.@])|\G(?!\A))[^.@](?:([^.@])(?=[.@]))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:^|(?<=@))([^.@])|\\G(?!\\A))[^.@](?:([^.@])(?=[.@]))?', 'gm')
const str = `userone@domain.com
usertwo@domain.com.co`;
const subst = `$1*$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);