use strict;
my $str = 'userone@domain.com
usertwo@domain.com.co';
my $regex = qr/(?:(?:^|(?<=@))([^.@])|\G(?!\A))[^.@](?:([^.@])(?=[.@]))?/mp;
my $subst = '$1*$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";