$re = '/(?:(?:^|(?<=@))([^.@])|\G(?!\A))[^.@](?:([^.@])(?=[.@]))?/m';
$str = 'userone@domain.com
usertwo@domain.com.co';
$subst = "$1*$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;