import Foundation
let pattern = #"(?:(?:^|(?<=@))([^.@])|\G(?!\A))[^.@](?:([^.@])(?=[.@]))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
userone@domain.com
usertwo@domain.com.co
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1*$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)