re = /(?:(?:^|(?<=@))([^.@])|\G(?!\A))[^.@](?:([^.@])(?=[.@]))?/m
str = 'userone@domain.com
usertwo@domain.com.co'
subst = '$1*$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result