#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<value>^Interface ethernet1\/4.(?<text>25[0-6]|(2[0-4]|1\d|[1-9])\d|[1-9]).*):.*"
Local $sString = "Interface ethernet1/4.101(DEMO_101_interface): Operational status" & @CRLF & _
"Interface ethernet1/4.182(TELCO_MGMT_interface): Operational status" & @CRLF & _
"Interface ethernet1/4.75(GUEST_interface): Operational status" & @CRLF & _
"Interface ethernet1/4.183(TELCO_DATA_interface)" & @CRLF & _
"Interface ethernet1/4.77(Hardware_MGMT_interface):" & @CRLF & _
"Interface ethernet1/4" & @CRLF & _
"Interface ethernet1/10(): Operational status" & @CRLF & _
"Interface ethernet1/1(INSIDE): Bits sent" & @CRLF & _
"Interface ethernet1/4(): Operational status" & @CRLF & _
"Interface ethernet1/4():"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")