# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<value>^Interface ethernet1\/4.(?<text>25[0-6]|(2[0-4]|1\d|[1-9])\d|[1-9]).*):.*"
test_str = ("Interface ethernet1/4.101(DEMO_101_interface): Operational status\n"
"Interface ethernet1/4.182(TELCO_MGMT_interface): Operational status\n"
"Interface ethernet1/4.75(GUEST_interface): Operational status\n"
"Interface ethernet1/4.183(TELCO_DATA_interface)\n"
"Interface ethernet1/4.77(Hardware_MGMT_interface):\n"
"Interface ethernet1/4\n"
"Interface ethernet1/10(): Operational status\n"
"Interface ethernet1/1(INSIDE): Bits sent\n"
"Interface ethernet1/4(): Operational status\n"
"Interface ethernet1/4():")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.