// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<value>^Interface ethernet1\/4.(?<text>25[0-6]|(2[0-4]|1\d|[1-9])\d|[1-9]).*):.*").unwrap();
let string = "Interface ethernet1/4.101(DEMO_101_interface): Operational status
Interface ethernet1/4.182(TELCO_MGMT_interface): Operational status
Interface ethernet1/4.75(GUEST_interface): Operational status
Interface ethernet1/4.183(TELCO_DATA_interface)
Interface ethernet1/4.77(Hardware_MGMT_interface):
Interface ethernet1/4
Interface ethernet1/10(): Operational status
Interface ethernet1/1(INSIDE): Bits sent
Interface ethernet1/4(): Operational status
Interface ethernet1/4():";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}