import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<value>^Interface ethernet1\\/4.(?<text>25[0-6]|(2[0-4]|1\\d|[1-9])\\d|[1-9]).*):.*";
final String string = "Interface ethernet1/4.101(DEMO_101_interface): Operational status\n"
+ "Interface ethernet1/4.182(TELCO_MGMT_interface): Operational status\n"
+ "Interface ethernet1/4.75(GUEST_interface): Operational status\n"
+ "Interface ethernet1/4.183(TELCO_DATA_interface)\n"
+ "Interface ethernet1/4.77(Hardware_MGMT_interface):\n"
+ "Interface ethernet1/4\n"
+ "Interface ethernet1/10(): Operational status\n"
+ "Interface ethernet1/1(INSIDE): Bits sent\n"
+ "Interface ethernet1/4(): Operational status\n"
+ "Interface ethernet1/4():";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}