const regex = /(?<value>^Interface ethernet1\/4.(?<text>25[0-6]|(2[0-4]|1\d|[1-9])\d|[1-9]).*):.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<value>^Interface ethernet1\\\/4.(?<text>25[0-6]|(2[0-4]|1\\d|[1-9])\\d|[1-9]).*):.*', 'gm')
const str = `Interface ethernet1/4.101(DEMO_101_interface): Operational status
Interface ethernet1/4.182(TELCO_MGMT_interface): Operational status
Interface ethernet1/4.75(GUEST_interface): Operational status
Interface ethernet1/4.183(TELCO_DATA_interface)
Interface ethernet1/4.77(Hardware_MGMT_interface):
Interface ethernet1/4
Interface ethernet1/10(): Operational status
Interface ethernet1/1(INSIDE): Bits sent
Interface ethernet1/4(): Operational status
Interface ethernet1/4():`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}