package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^/\n]*/)?([^^\n]*)\^.*`)
var str = `AMAZON PAYMENTS EUROPE S.C.A.
1/asdfL GE#EFRDA^9212 GRIFF
Frau HUSEL G^9212 GRIFF`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}