use strict;
my $str = 'AMAZON PAYMENTS EUROPE S.C.A.
1/asdfL GE#EFRDA^9212 GRIFF
Frau HUSEL G^9212 GRIFF';
my $regex = qr~^(?:[^/\n]*/)?([^^\n]*)\^.*~mp;
my $subst = '\\1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";