re = /^(?:[^\/\n]*\/)?([^^\n]*)\^.*/m
str = 'AMAZON PAYMENTS EUROPE S.C.A.
1/asdfL GE#EFRDA^9212 GRIFF
Frau HUSEL G^9212 GRIFF'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result