import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^/\\n]*/)?([^^\\n]*)\\^.*";
final String string = "AMAZON PAYMENTS EUROPE S.C.A.\n"
+ "1/asdfL GE#EFRDA^9212 GRIFF\n"
+ "Frau HUSEL G^9212 GRIFF";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}