# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[^/\n]*/)?([^^\n]*)\^.*"
test_str = ("AMAZON PAYMENTS EUROPE S.C.A.\n"
"1/asdfL GE#EFRDA^9212 GRIFF\n"
"Frau HUSEL G^9212 GRIFF")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.