#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z0-9\-]{5,30}$"
Local $sString = "98b8d46a4484729c712a79d7473bdc23" & @CRLF & _
"98b8d46a4484729c712a79d7473bdc" & @CRLF & _
"5-35XES36D" & @CRLF & _
"20160401150146120SME099935"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")