// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z0-9\-]{5,30}$").unwrap();
let string = "98b8d46a4484729c712a79d7473bdc23
98b8d46a4484729c712a79d7473bdc
5-35XES36D
20160401150146120SME099935";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}