const regex = new RegExp('^[A-Za-z0-9\\-]{5,30}$', 'gm')
const str = `98b8d46a4484729c712a79d7473bdc23
98b8d46a4484729c712a79d7473bdc
5-35XES36D
20160401150146120SME099935`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}