#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\$?(\d{1,3},(\d{3},)*\d{3}|\d+)(.\d{1,4})?$"
Local $sString = "2,000,000" & @CRLF & _
"200000.0000" & @CRLF & _
"200" & @CRLF & _
"200.00000" & @CRLF & _
"2,000.00" & @CRLF & _
"2,0,00.00" & @CRLF & _
"1,234,456.7890" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")