import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\$?(\\d{1,3},(\\d{3},)*\\d{3}|\\d+)(.\\d{1,4})?$";
final String string = "2,000,000\n"
+ "200000.0000\n"
+ "200\n"
+ "200.00000\n"
+ "2,000.00\n"
+ "2,0,00.00\n"
+ "1,234,456.7890\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}