$re = '/^\$?(\d{1,3},(\d{3},)*\d{3}|\d+)(.\d{1,4})?$/m';
$str = '2,000,000
200000.0000
200
200.00000
2,000.00
2,0,00.00
1,234,456.7890
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);