const regex = /(Die\s*?(?:<\/?[^>]*?>)?\s*?erste\s*?(?:<\/?[^>]*?>)?\s*?Ausgabe\s*?(?:<\/?[^>]*?>)?\s*?der\s*?(?:<\/?[^>]*?>)?\s*?Avenue\s*?(?:<\/?[^>]*?>)?\s*?beschäftigt\s*?(?:<\/?[^>]*?>)?\s*?sich\s*?(?:<\/?[^>]*?>)?\s*?mit\s*?(?:<\/?[^>]*?>)?\s*?dem\s*?(?:<\/?[^>]*?>)?\s*?Konzept\s*?(?:<\/?[^>]*?>)?\s*?und\s*?(?:<\/?[^>]*?>)?\s*?der\s*?(?:<\/?[^>]*?>)?\s*?Geschichte\s*?(?:<\/?[^>]*?>)?\s*?des\s*?(?:<\/?[^>]*?>)?\s*?Cyborgs\.)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Die\\s*?(?:<\\\/?[^>]*?>)?\\s*?erste\\s*?(?:<\\\/?[^>]*?>)?\\s*?Ausgabe\\s*?(?:<\\\/?[^>]*?>)?\\s*?der\\s*?(?:<\\\/?[^>]*?>)?\\s*?Avenue\\s*?(?:<\\\/?[^>]*?>)?\\s*?beschäftigt\\s*?(?:<\\\/?[^>]*?>)?\\s*?sich\\s*?(?:<\\\/?[^>]*?>)?\\s*?mit\\s*?(?:<\\\/?[^>]*?>)?\\s*?dem\\s*?(?:<\\\/?[^>]*?>)?\\s*?Konzept\\s*?(?:<\\\/?[^>]*?>)?\\s*?und\\s*?(?:<\\\/?[^>]*?>)?\\s*?der\\s*?(?:<\\\/?[^>]*?>)?\\s*?Geschichte\\s*?(?:<\\\/?[^>]*?>)?\\s*?des\\s*?(?:<\\\/?[^>]*?>)?\\s*?Cyborgs\\.)', 'g')
const str = `<p>Die erste Ausgabe der Avenue beschäftigt sich mit dem Konzept und der Geschichte des Cyborgs. Dabei geht es um <em>Human Enhancement</em>,<em> Darth Vader</em>, <em>Robocop <span class="amp">&</span> Co</em>., vor allem aber: um uns.</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}