re = /(Die\s*?(?:<\/?[^>]*?>)?\s*?erste\s*?(?:<\/?[^>]*?>)?\s*?Ausgabe\s*?(?:<\/?[^>]*?>)?\s*?der\s*?(?:<\/?[^>]*?>)?\s*?Avenue\s*?(?:<\/?[^>]*?>)?\s*?beschäftigt\s*?(?:<\/?[^>]*?>)?\s*?sich\s*?(?:<\/?[^>]*?>)?\s*?mit\s*?(?:<\/?[^>]*?>)?\s*?dem\s*?(?:<\/?[^>]*?>)?\s*?Konzept\s*?(?:<\/?[^>]*?>)?\s*?und\s*?(?:<\/?[^>]*?>)?\s*?der\s*?(?:<\/?[^>]*?>)?\s*?Geschichte\s*?(?:<\/?[^>]*?>)?\s*?des\s*?(?:<\/?[^>]*?>)?\s*?Cyborgs\.)/
str = '<p>Die erste Ausgabe der Avenue beschäftigt sich mit dem Konzept und der Geschichte des Cyborgs. Dabei geht es um <em>Human Enhancement</em>,<em> Darth Vader</em>, <em>Robocop <span class="amp">&</span> Co</em>., vor allem aber: um uns.</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end