// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(Die\s*?(?:<\/?[^>]*?>)?\s*?erste\s*?(?:<\/?[^>]*?>)?\s*?Ausgabe\s*?(?:<\/?[^>]*?>)?\s*?der\s*?(?:<\/?[^>]*?>)?\s*?Avenue\s*?(?:<\/?[^>]*?>)?\s*?beschäftigt\s*?(?:<\/?[^>]*?>)?\s*?sich\s*?(?:<\/?[^>]*?>)?\s*?mit\s*?(?:<\/?[^>]*?>)?\s*?dem\s*?(?:<\/?[^>]*?>)?\s*?Konzept\s*?(?:<\/?[^>]*?>)?\s*?und\s*?(?:<\/?[^>]*?>)?\s*?der\s*?(?:<\/?[^>]*?>)?\s*?Geschichte\s*?(?:<\/?[^>]*?>)?\s*?des\s*?(?:<\/?[^>]*?>)?\s*?Cyborgs\.)").unwrap();
let string = "<p>Die erste Ausgabe der Avenue beschäftigt sich mit dem Konzept und der Geschichte des Cyborgs. Dabei geht es um <em>Human Enhancement</em>,<em> Darth Vader</em>, <em>Robocop <span class=\"amp\">&</span> Co</em>., vor allem aber: um uns.</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}