using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""cid:[a-f0-9-]*\"">[^<]+<\/a>";
string input = @"<a href=""cid:c524ae03-7ac7-4823-9a28-af17a6acf12f"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}