re = /\"cid:[a-f0-9-]*\">[^<]+<\/a>/
str = '<a href="cid:c524ae03-7ac7-4823-9a28-af17a6acf12f">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end