$re = '/\"cid:[a-f0-9-]*\">[^<]+<\/a>/';
$str = '<a href="cid:c524ae03-7ac7-4823-9a28-af17a6acf12f">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);