// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\"cid:[a-f0-9-]*\">[^<]+<\/a>"#).unwrap();
let string = "<a href=\"cid:c524ae03-7ac7-4823-9a28-af17a6acf12f\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}